В электронную таблицу занесли результаты муниципального этапа олимпиады по программированию В столбце А указаны фамилия и имя учащегося

gdz-informatika-9-klass-bosova-2021

§ 3.2. Организация вычислений в электронных таблицах Гдз по информатике 9 класс по учебнику Босова. Базовый уровень. Обновленные ФГОС 2021 год.


18. В электронную таблицу занесли результаты муниципального этапа олимпиады по программированию:

В электронную таблицу занесли результаты муниципального этапа олимпиады по программированию В столбце А указаны фамилия и имя учащегося

В столбце А указаны фамилия и имя учащегося; в столбцах В и С — класс и школа, в которой он учится; в столбцах D, E, F — баллы, полученные учеником за решение каждой из олимпиадных задач. За каждую задачу можно получить от 0 до 25 баллов. Всего в электронную таблицу занесены данные 115 учащихся. Гарантируется, что есть ученики, правильно решившие все задачи. Порядок записей в таблице произвольный. Определите, значения каких величин будут получены в результате последовательного выполнения вычислений по следующим формулам.

1) =СУММ(D2:F2) Формула находится в ячейке G2 и копируется в диапазон G3:G116.

2) =МАКС(G2:G116) Формула находится в ячейке G117.

3) =ЕСЛИ(G2=$G$117;»Победитель!»;»») Формула находится в ячейке H2 и копируется в диапазон H3:H116.

4) =СЧЁТЕСЛИ(В2:В116;»=7″) Формула находится в ячейке В117.

5) =СУММ(D2:F2)*100/75 Формула находится в ячейке I2 и копируется в диапазон I3:I116.

6) =СРЗНАЧ(F2:F116) Формула находится в ячейке F117.

7) =ЕСЛИ(И(G2<$G$117;I2>80);»Призёр»;»») Формула находится в ячейке J2 и копируется в диапазон J3:J116.

8) =СЧЁТЕСЛИ(J2:J116;»Призёр») Формула находится в ячейке J117.

9) =ЕСЛИ(С2=»Ивановская СОШ»;D2+E2+F2;»») Формула находится в ячейке K2 и копируется в диапазон K3:K116.

Ответ

1) =СУММ(D2:F2) Формула находится в ячейке G2 и копируется в диапазон G3:G116.
Сумма баллов каждого учащегося за 3 задачи.


2) =MAKC(G2:G116) Формула находится в ячейке G117.
Количество баллов, который набрал ученик с наивысшим баллов среди всех учащихся.


3) =ЕСЛИ(G2=117; «Победитель!»;» «) Формула находится в ячейке Н2 и копируется в диапазон Н3:Н116.
Сравнивает полученные баллы каждого учащегося с наивысшим баллом среди всех, если равно то выводится Победитель, если нет то пустая строка.


4) =СЧЕТЕСЛИ(В2:В116;»=7″) Формула находится в ячейке В117.
Считает количество учеников из 7-го класса.


5) =CУММ(D2:F2)*100/75 Формула находится в ячейке I2 и копируется в диапазон I3:I116.
Процент набранных баллов учащегося.


6) =СРЗНАЧ(F2:F116) Формула находится в ячейке F117.
Среднее количество баллов среди учащихся за 3-ю задачу.


7) =ЕСЛИ(И(G2<117;I2>80); «Призер»;»») Формула находится в ячейке J2 и копируется в диапазон J3:J116.
Если участник не стал победителем, но набрал больше 80 баллов, то становится призёром


8) =СЧЕТЕСЛИ(J2:J116;»Призер») Формула находится в ячейке J117.
Подсчет количества призёров


9) =ЕСЛИ(С2=»Ивановская СОШ»;D2+E2+F2;»») Формула находится в ячейке К2 и копируется в диапазон К3:К116.
Вывод количества баллов всех учащихся Ивановской СОШ

Понравилась статья? Поделиться с друзьями: