Составьте в среде КуМир алгоритм, под управлением которого Робот обойдёт прямоугольную область, обнесённую стеной, по периметру и закрасит угловые клетки.

ГДЗ информатика 8 класс

Гдз по информатике 8 класс по учебнику Босова. Базовый уровень. Обновленные ФГОС 2021 год. § 3.6. Алгоритмическая конструкция «повторение». Циклические алгоритмы


2. Составьте в среде КуМир алгоритм, под управлением которого Робот обойдёт прямоугольную область, обнесённую стеной, по периметру и закрасит угловые клетки. Размеры области неизвестны.

Составьте в среде КуМир алгоритм, под управлением которого Робот обойдёт прямоугольную область, обнесённую стеной, по периметру и закрасит угловые клетки.

Ответ

Первую клетку закрашиваем сразу. Дальше идем вправо вдоль верхней границы, пока справа свободно, когда упремся в стену — значит, достигли угловой клетки. Закрашиваем её и продолжаем так же с движением вниз (в нижнюю правую клетку), влево (в нижнюю левую) и вверх (в начальную верхнюю левую).

Алгоритм (для примера на Кумире):

использовать Робот

алг Обход по периметру

нач

 закрасить

 нц пока справа свободно

   вправо

 кц

 закрасить

 нц пока снизу свободно

   вниз

 кц

 закрасить

 нц пока слева свободно

   влево

 кц

 закрасить

 нц пока сверху свободно

   вверх

 кц

кон


Понравилась статья? Поделиться с друзьями: